Speedport-Router und moderne Browser

Beim elterlichen Tech-Support gelernt: Speedport-Router der Telekom (hier konkret der W 503V Modell C) haben sehr seltsame Firmware.

Zuerst fällt auf, dass sich das Passwort auf der Konfigurationsseite nicht eingeben lässt. Das Eingabefeld ist inaktiv. Kurzes Suchen im Netz führt zur Erkenntnis: Das ist bei den Kisten nach langer Laufzeit einfach so. Aus- und wieder Einschalten “löst” das Problem.

Dann die nächste Überraschung: Das SSL-Zertifikat ist abgelaufen. Seit dem 7.1.2013. Hmm… da gibt’s doch sicher schon ein Firmwareupdate, oder? Nein, natürlich nicht. Sieht die Telekom gar nicht ein und lässt die User statt dessen einen wirren Unsicherheitstanz aufführen.  Also heimlich, still und leise die SSL-Konfiguration der Browser so ändern, dass der Zugriff auf den Speedport noch geht und die Erklärung, wann so eine SSL-gesicherte Seite denn jetzt sicher ist, doch noch gilt. Das sollen Geräte für Enduser sein?

OK, dann irgendwann also der erfolgreiche Login ins Konfigurationsinterface. Außer… ja, außer man ist mit dem Firefox unterwegs und hat den standardmäßig auf “do-not-track” gestellt (im deutschen “Websites mitteilen, meine Aktivitäten nicht zu verfolgen”). Damit schlägt der Login reproduzierbar fehl.

Also, wer einen Speedport hat, der sich mit dem Firefox nicht konfigurieren lässt: Einfach mal do-not-track ausschalten… oder den Router ein letztes Mal verwenden, um sich im Netz was besseres zu bestellen. Wirklich gruselig, was die Telekom da technischen Laien für Software zumutet.

Alles neu

Nachdem meine alte Seit langsam hoffnungslos veraltet war, habe ich mich entschlossen, hier komplett neu anzufangen — neue Technik, neue Inhalte, neues Design. In den nächsten Tagen ist hier deshalb Baustelle.